Tuesday, July 01, 2008

さてさて...

ZIPHONE'S BLOG:Well, well...


さて,日々ZiPhoneを作っていますが...
上の画像はフェイクじゃない.
最適な方法ではないが,すごい事だ.
なんとか,iPhone 2.0ファームがiPod touch 32G上で動くようになった.
全ての機能が使える.
Windows(あるいはmac)からインストールするのに,
特別なベータ版のiTunesが必要だ.
installer.appやサードパティアプリを無くしたくなければ,
iPod touch, iPhoneどちらも2.0にアップグレードしないことをおすすめする.

もし2.0にアップしてしまった場合,iPod touchをダウングレードするには,
まずiTunes7.7をアンインストールして,
iTunes7.5を再度インストールする必要がある.
次に,iPod touchをDFUモードにし,1.1.4にフルリストアする.
そしてZiPhoneを使えば,installer.appやサードパティアプリを元に戻せる.

iPhoneの手順はもっと複雑だ.
basebandもダウングレードしなければいけない.

とりあえず,これができる新しいZiPhoneの暫定バージョンは出来てるけど.

今のところ,出来る事と言えば
1)これを信じて,2.0にアップグレードしないで待つ
2)installer.appと自由に別れを告げて,2.0にする

もうちょっと待っててね:)
Zibri

Well, here I am still...
The picture above is not a fake.
It's not even a major breakthru but it's something.
I am glad to tell you anyhow that 2.0
firmware works pretty well on my iPod 32gb.
All features are enabled.
To install it from windows (or mac) you need
a special beta version of itunes.
Unless you want to loose installer
and all third party apps I strongly suggest you
NOT TO UPGRADE (both iPod both iPhone).
To downgrade the iPod you will need
to uninstall iTunes 7.7 and reinstall 7.5.
Then you will need to put the iPod in DFU mode
and do a full restore back to 1.1.4 (and use ZiPhone)
to have back Installer and all goodies.
With the iPhone it's more complicated
because you will also need to
downgrade the baseband.
I already have a very preliminary version
of the new ZiPhone which will allow that.

As of today you will have 2 choices:
1) Believe in the community and don't upgrade to 2.0
2) Say goodbye to Installer and freedom and upgrade.

Stay tuned :)
Zibri

No comments: